Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Degraded uploads
Incident Report for Box
Resolved
Uploads have returned to normal as of 12:45PM PDT. We apologize for any inconvenience
Posted about 3 years ago. Oct 08, 2014 - 12:45 PDT
Monitoring
Uploads may have been degraded for some customers between 11:40AM and 12:45PM PDT. Uploads are currently functioning as expected.
Posted about 3 years ago. Oct 08, 2014 - 11:40 PDT
This incident affected: Uploads.