Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Slower downloads.
Incident Report for Box
Resolved
As of 1:47 PM PDT, the issue with users experiencing slow downloads is resolved.
Posted over 2 years ago. Oct 13, 2014 - 14:18 PST
Investigating
As of 11:20AM PDT, some users may be experiencing slower downloads. We're currently investigating.
Posted over 2 years ago. Oct 13, 2014 - 12:07 PST
This incident affected: Downloads.