Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Delayed email notifications
Incident Report for Box
Resolved
09/16/2014 10:40 pm (PDT) - All batched email queues were cleared and sending has returned to normal.
Posted over 2 years ago. Sep 16, 2014 - 22:40 PST
Identified
Some email notifications may have been delayed for some users since 1:24pm PDT.
Posted over 2 years ago. Sep 16, 2014 - 13:24 PST
This incident affected: Email Notifications.