Status updates may be delayed up to 15 minutes.
Timestamps noted under an update may not reflect actual start/end times.

Please scroll past the table below for planned maintenance notifications.

Slower uploads and downloads
Incident Report for Box
Resolved
Uploads and download have returned to normal as of 10:14 a.m. PDT. We apologize for any inconvenience.
Posted almost 3 years ago. Oct 06, 2014 - 10:14 PDT
Investigating
Starting at 7:00am PDT, some users may be experiencing slower uploads and downloads. We're currently investigating.
Posted almost 3 years ago. Oct 06, 2014 - 07:00 PDT
This incident affected: Downloads and Uploads.