For more information about our Incident Response and Communications please read this support article.

We also maintain a list of Known Product Issues separate from this site here.

Problem with Sign-In to Support.Box.Com to Submit/View Cases
Incident Report for Box
Resolved
The problem with the 'sign-in' option to submit/update cases on Box Support site (https://support.box.com) is resolved. Customers can now submit/update cases through the site.
Posted Feb 26, 2015 - 09:14 PST
Identified
The Box Support site at https://support.box.com is currently not permitting use of the 'sign-in' option to submit/update cases. As a workaround, customers can access the Box Support site from the 'Help' link in their Box Webapp session.
Posted Feb 26, 2015 - 07:30 PST